Behoben [App] Kein Angriffsalarm

Dieses Thema im Forum "Behobene Fehler" wurde erstellt von Stevie2, 03.09.18.

  1. Stevie2

    Stevie2

    Beigetreten:
    15.02.15
    Beiträge:
    782
    Zustimmungen:
    223
    Spieler-ID: 8295929 (Stevie2)
    Spielwelt: de73 - Hermonassa, de81 - Rhamnous, de84 - Zancle, de85 - Abdera, de92 - Imbros
    Browser: Vivaldi
    und Android-App

    Seit einiger Zeit (ich kann keine genaue Zeitangabe machen) funktioniert der Angriffssound ingame und bei der App nur sehr unzuverlässig.
    Ist im Browser der Tab im Hintergrund und Angriffe kommen rein, gibt es keinen Angriffsalarm (auch nicht von den Scripten). Erst wenn man den Tab aufruft, bekommt man den Alarm zu hören und das sogar wenn die Angriffe schon längst durch sind
    Auch wenn der Tab aktiv ist und ich mich selbst angreife oder eine Inselquest mich angreift, gibt es keinen Angriffsalarm.
    Sogar die App macht keinen Mucks und das Handy liegt die meiste Zeit an der gleichen Stelle, wo der beste Empfang ist.
    Im Browser funktioniert der Alarm ab und zu, wenn man den Tab komplett neu lädt, aber wer macht das schon, wenn er eh sieht, dass er angegriffen wird?

    Desweiteren habe ich vor ein paar Tagen mehrere EOs gestartet, wobei bei einer EO das Kolo nach nur 5 Minuten gekickt wurde. Oben in der Leiste war aber immer noch die EO zu sehen und wenn man anklickte, gab es eine Meldung, dass die EO nicht vorhanden ist. Um zu sehen, was passiert, hab ich den Tab erst nach über einer Stunde, in der ich meinen Account völlig normal bespielt habe, neu geladen und erst dann war auch die EO verschwunden.

    Ebenso spiele ich auf den Welten Rhamnous und Abdera, die beide im Countdown sind. Mein Laptop wird nachts runter gefahren und morgens wieder gestartet, wobei natürlich alle Tabs neu laden. Allerdings wurde trotz des tägl. Neu ladens der Countdown falsch angezeigt. Auf Abdera wurden mir 6 Tage angezeigt, obwohl es nur noch 2 Tage waren, was erst nach nochmaligem neu laden korrigiert wurde. Auf Rhamnous ist es ähnlich, dort wurden mir 8 Tage angezeigt, obwohl es tatsächlich nur noch 4 Tage waren.

    Dass etwas mal nicht sofort aktualisiert sind wir ja alle gewohnt, aber dass so vieles nicht aktualisiert und besonders der Angriffsalarm selbst bei aktivem Tab nicht anschlägt und auch die App nicht anschägt, geht mMn einfach gar nicht.

    Eine genaue Zeitangabe, seit wann das auftritt kann ich nicht machen, aber ich hab das Gefühl, dass es seit dem letzen Update so extrem ist.
     
  2. Fredy46

    Fredy46

    Beigetreten:
    13.10.11
    Beiträge:
    1.035
    Zustimmungen:
    63
    das erlebe ich in verschiedensten Teilbereichen ähnlich
    Zum Beispiel wenn ich on komme, sehe das alle Lager rot sind in der Stadt und gleich so viel wie möglich verbaue.
    Die Bauschleifen sind dann gefüllt aber die Anzeige bleibt weiterhin bei allen Lagern rot.
    Erst wenn ich zur nächsten Stadt wechsle und wieder zurück dann sehe ich den tatsächlichen Lagerstand.

    Da werden wohl so einige Scripte nicht sauber übertragen ?
    Ein Problem das ich in meinem Grepoleben schon öfters erlebt habe. Na hauptsache die Server laufen "störungsfrei" ^^

    // Edit
    Das ist auch so ein Fehler den ich immer öfters sehen, aber von früher mich nicht erinnern kann das es vorgekommen ist (in keinem Fall in dieser Häufung)
    [​IMG]
     
    Zuletzt bearbeitet: 03.09.18
  3. Mim le Fay

    Mim le Fay

    Beigetreten:
    30.04.12
    Beiträge:
    7.720
    Zustimmungen:
    843
    Das wird ein Cache Problem sein

    Beim aus- und wieder anknipsen des Computers lädt er die Daten aus dem Cache und nicht vom Anbieterserver.

    Muss also vom Anbieter so verändert werden, das veränderliche Daten regelmäßig vom Server aktualisiert werden, allerdings wird das dann wieder Performanceeinbrüche bringen, Man kann halt nur auf einer Hochzeit tanzen :wink:
     
  4. AnWePe

    AnWePe

    Beigetreten:
    20.07.15
    Beiträge:
    1.807
    Zustimmungen:
    566

    ich hab das ganze andersrum und das find ich viel nerviger

    resies an ne stadt senden wo z.b. fs held drin is und weder die bhp noch die lager aktualisieren sich nachdem man was in die schleife gemacht hat oder wenn lieferungen ankamen, kannste nur manuell überwachen und nach jedem slot f5 drücken das geht mir tierisch auf den Senkel und hat scho etliche Resies gekostet
     
  5. Gaius Iulius Caesar

    Gaius Iulius Caesar Grepolis Team Community Manager

    Beigetreten:
    20.09.11
    Beiträge:
    2.507
    Zustimmungen:
    665
    In Bezug auf den Angriffsalarm können wir die Probleme bestätigen und haben sie bereits weitergeleitet. Ich halte euch auf dem Laufenden.
     
    prime 7 und Stevie2 gefällt das.
  6. Fredy46

    Fredy46

    Beigetreten:
    13.10.11
    Beiträge:
    1.035
    Zustimmungen:
    63
    ja kann ich auch bestätigen
    Das gehört für mein empfinden alles in die gleiche "Schublade" das es hier schlicht insgesamt Proble mit einer sauberen Skriptübertragung gibt.

    ich denke nicht das das ein Problem vom Cache ist(zumindest vielleicht indirekt aber nicht ursächlich)
    Wenn ich offline bin und beim wieder on kommen das wie oben im Screenshot vorfinde, dann wurden die Veränderungen die in meiner offline-Zeit passiert sind beim wieder online kommen, einfach nicht vollständig vom Server zu mir übertragen.
    Und nur in dem Fall könnte ich mir vorstellen dass dann etwas aus dem Cache geladen wird, weil eben die aktuellen Daten vom Server nicht geschickt wurden.
     
  7. Mim le Fay

    Mim le Fay

    Beigetreten:
    30.04.12
    Beiträge:
    7.720
    Zustimmungen:
    843
    Damit hast Du genau das gleiche gesagt, wie ich es schon beschrieb.
    Ob nu das Frontend so programmiert wurde, dass er Cache Daten bevorzugt benutzt oder die Serversoftware das nur einfach nicht schickt und er sich deswegen aus dem Cache bedient...

    Wobei um ehrlich zu sein beim Schreiben stelle ich fest, dass das Blödsinn ist. Hätte man ihn programmiert das er sich die Daten vom Server lädt hätte man ihm gar nicht gesagt, wo er die Daten im Cache findet. Und wenn er nix findet oder nix hochlädt, dann kommt halt einfach nix... hatten wir auch schon mal, keine Grafiken zum Beispiel.
     
  8. Fredy46

    Fredy46

    Beigetreten:
    13.10.11
    Beiträge:
    1.035
    Zustimmungen:
    63
    Wer "ratet besser". Wäre dann ein neues Spiel im Community-Bereich :biggrin:
     
  9. Gaius Iulius Caesar

    Gaius Iulius Caesar Grepolis Team Community Manager

    Beigetreten:
    20.09.11
    Beiträge:
    2.507
    Zustimmungen:
    665
    @Buffysara und alle anderen: Wir bräuchten zu Reproduktionszwecken beispielhaft noch weitere Informationen zu euren Smartphones: Handymodell und verwendetes Betriebssystem samt Versionsnummer wären da super.

    Zum Browser wurde mir gesagt, dass der Angriffswarner nur ausgelöst wird, wenn ihr Aktionen im Spiel ausführt, also zumindest den Browsertab offen habt und dieser sich aktualisiert. Das hängt damit zusammen, dass diese Informationen nicht vom Server gepusht werden, sondern von euch durch Aktionen gepullt werden müssen.
     
  10. Buffysara

    Buffysara

    Beigetreten:
    03.09.12
    Beiträge:
    6.556
    Zustimmungen:
    1.515
    äh wieso ich?

    Browser ging früher auch wenn der Tab offen war aber nicht aktiv
     
  11. Draba Aspera

    Draba Aspera

    Beigetreten:
    01.12.11
    Beiträge:
    6.706
    Zustimmungen:
    2.244
    Diese Aussage ist leider immer noch so falsch wie das erste Mal, als sie hier im Forum auftauchte (damals von Justus aufgestellt, wenn ich mich nicht irre).

    Wäre das so, wäre es nämlich nutzlos, den Rechner nachts laufen zu lassen in Hörweite, da man ohnehin keinen akustischen Angriffsalarm (den spielinternen) erhalten würde, während man selbst nichts macht im Account oder in einem Hintergrundtab. Der Angriffsalarm kommt aber durchaus, auch wenn man stundenlang keine eigenen Aktionen ausgeführt hat, und auch in Tabs im Hintergrund. Immer wenn diese Standardfunktionen des Spiel lahmen (und ich spreche jetzt von der Browserversion), bekommt man anhand der Reaktionen aus Hamburg den Eindruck, dass einigen Mitarbeitern nicht bekannt ist, wie die fraglichen Features eigentlich funktionieren (sollten).

    Also nochmal: Der spielinterne Angriffsalarm geht auch dann los, wenn man selbst keine Aktionen im Account ausführt (und schon seit Stunden keine Aktionen ausgeführt hat), und er geht auch in den nicht aktiven Hintergrundtabs los, wie ich sehr gut weiß aus der Zeit, in der ich drei Betas und zwei Livewelten parallel spielte, und erstere teilweise ohne Nachtbonus.
     
  12. Gaius Iulius Caesar

    Gaius Iulius Caesar Grepolis Team Community Manager

    Beigetreten:
    20.09.11
    Beiträge:
    2.507
    Zustimmungen:
    665
    Ich verstehe eure Einwände, ich habe dieselben gebracht. Mir wurde es so erklärt, dass der Browser erlauben muss, dass Infos abgefragt werden. Dann kann es auch zu einer Abfrage kommen, ohne dass im Tab Aktionen ausgeführt werden. Ich habe es auf jeden Fall so weitergeleitet und werde auch noch einmal nachhaken.

    Oh sorry Buffy, ich war mir irgendwie sicher, du hättest den Thread erstellt. Ich meinte natürlich Stevie.
     
  13. Buffysara

    Buffysara

    Beigetreten:
    03.09.12
    Beiträge:
    6.556
    Zustimmungen:
    1.515
    Ich hab da zwar noch ein nettes Add on das den Tab aktualisiert wenn er nicht aktiv ist (Zeit einstellbar) aber das kann es ja auch nicht sein.
    Zumal ich das eigentlich nicht benutzen will.
     
  14. Draba Aspera

    Draba Aspera

    Beigetreten:
    01.12.11
    Beiträge:
    6.706
    Zustimmungen:
    2.244
    Das hat nichts mit Einwänden zu tun, sondern mit widersprüchlichen und teilweise nicht korrekten Aussagen aus Hamburg. Zwischen der Aussage, dass der "Browser erlauben muss, dass Infos abgefragt werden", "der Browser muss auch in den nicht aktiven Tabs Aktualisierungen zulassen" und "die Abfrage muss durch eure Aktionen im Account gepullt werden" liegen Welten. Man kann zwar in den Browsereinstellungen unterdrücken, dass Hintergrundtabs aktualisiert werden, aber bei den meisten mir bekannten Browsern handelt es sich bei der Aktualisierung von Hintergrundtabs um eine Standardeinstellung. Wenn diese aktiv ist, und ohne Änderungen durch den User der Sound in nicht aktiven Tabs nicht mehr funktioniert, dann wurde von InnoGames eine Änderung vorgenommen, die dies verursacht - meist als Nebenprodukt sogenannter "Performanceverbesserungen", die von Leuten durchgeführt werden, die entweder nicht spielen, oder nie angegriffen werden.

    Ich habe da schon mal einen entsprechenden Kampf geführt, ich weiß also, wovon ich spreche...^^
     
    Stevie2 gefällt das.
  15. Fredy46

    Fredy46

    Beigetreten:
    13.10.11
    Beiträge:
    1.035
    Zustimmungen:
    63
    Heist das jetzt, ich bräuchte nur bestimmte Browser-Einstellungen zu verändern(welche?) dann sollte das mit dem "einfrieren" wenn nicht aktives Fenster/Tab, behoben sein ?

    -mit dem Angriffswarner(Sound) der App hat es zumindest bei mir in letzter Zeit kein feststellbares Problem gegeben (Galaxy S6)
     
  16. Gaius Iulius Caesar

    Gaius Iulius Caesar Grepolis Team Community Manager

    Beigetreten:
    20.09.11
    Beiträge:
    2.507
    Zustimmungen:
    665
    "Aktionen im Account" kann auch eine Aktualisierung des Grepo-Tabs sein (nicht unbedingt über F5). Diese muss aber browserseitig getriggert werden.

    Nein, das ist nicht über die Browser-Einstellungen zu ändern. Es gibt - nach meinem jetzigen Kenntnisstand - keine Möglichkeit, das für den Browser zu ändern.

    Ich würde mich aber freuen, wenn ihr mir hier noch weitere Infos geben könntet.
    Es wird nun bereits an dem Fehler gearbeitet. Er scheint mit einer Android-Änderung bei den Push-Benachrichtigungen zusammenzuhängen.
     
    Zuletzt bearbeitet: 04.09.18
  17. Fredy46

    Fredy46

    Beigetreten:
    13.10.11
    Beiträge:
    1.035
    Zustimmungen:
    63
    bitte macht es in den Posts hier immer deutlich ob gerade vom Browser oder von der App geschrieben wird.

    Vielleicht so:

    Zur App
    ..........

    Zum Browser:
    ........


    ich glaube sonst wird es über kurz oder lang zu unnötigen Missverständnissen in diesem Thread kommen :)

    Galaxy S6 mit Android7, da hatte ich bis jetzt keine Probleme dass der Angriffsalarm nicht funktioniert hätte. (seit heute bin ich aber ohne Weltaccount, Abdera ist geschlossen -aaahhh welche himmlische Ruhe wieder mal :biggrin:)
     
    Zuletzt bearbeitet: 04.09.18
  18. Stevie2

    Stevie2

    Beigetreten:
    15.02.15
    Beiträge:
    782
    Zustimmungen:
    223
    Per Unterhaltung geschickt! [​IMG]
     
    Honigtatze, Faey und Gaius Iulius Caesar gefällt das.
  19. Draba Aspera

    Draba Aspera

    Beigetreten:
    01.12.11
    Beiträge:
    6.706
    Zustimmungen:
    2.244
  20. AnWePe

    AnWePe

    Beigetreten:
    20.07.15
    Beiträge:
    1.807
    Zustimmungen:
    566
    [​IMG]

    ach ja das mit dem kein app am PC wenn Tab minimiert ist, ist auch wenn Tab nicht der aktive ist.

    Z.B. hatte ich ja grad den Forumstab auf und dort halt gewerkelt und geschrieben, und weil ich mir scho dachte das Grepo wieder eingefroren ist hab ich mal nen Screenshot gemacht (ach ja und wenn mir einer vom Team mit boah das liegt an den Scripten kommt werd ich sauer^^ weil DAS hab ich auch ohne Scripte^^), man sieht super an den beiden Uhrzeiten das der Tab mit Grepo einfriert solange er ned aktiv ist (in dem Screenie warens halt "nur" 19 Minuten, aber in der Zeit kommt halt NULL an kein bericht keine attbenachrichtungen keine pns usw.)

    Broswer is in dem Fall Chrome
    Version 68.0.3440.106 (Offizieller Build) (64-Bit)

    und ja das habe ich auch mit der neuen Version^^
     

Seitenanfang