Neues Projekt: Grepostats + Grepomaps + vieles mehr als eigenständiges Programm

Also um jetzt noch mal auf die letzten paar Nachrichten einzugehen. Im Moment läuft das Tool noch..Grepolis hat bisher zum Glück keine großen Änderungen vorgenommen.

Pete wird wohl über kurz oder lang nicht mehr nach Grepolis zurück kommen (Aber man weiß ja nie..
)

Falls es irgendwann nicht mehr laufen sollte, werde ich versuchen das zu beheben bzw.wenn ich etwas mehr Zeit habe ändere ich vielleicht das ein oder andere auch. Das Problem ist, dass ich eine komplett neue Version erstellen müsste, da ich es nicht schaffe es so zu kompilieren dass Updates mit Pete's Version übereinstimmen...sprich: ich kann keine Updates für die Version 2.X erstellen


Noch mal für alle denen neue Welten fehlen: die lassen sich ohne Probleme selber hinzufügen..steht schon oft genug hier im Thread wie das geht.
 
Ich habe noch mal kurz geguckt was die Serverliste betrifft. Die neuste Version von Grepo-Tool ist 2.0.15 wenn ich das richtig sehe und die enthält einen Button um die Serverliste mit Tondas-Serverliste abzugleichen...zumindest für Server ohne russische Buchstaben sollte das auch funktionieren
 

toleranzgrenze

Gast
selbes problem wie von vorposter schon beschrieben...ich lade das tool herunter -> entpacke es in einen neuen ordner -> wähle eine welt die nicht geschlossen ist...dann lädt das teil...zum schluß erscheint:
failed to read.jpg
Wenn das Programm dann startet sehe ich nichts außer einem leeren Meer. Weiters kann ich unter "Settings" -> "Application" nichts auswählen. Wenn wer eine Lösung hat freu ich mich :)
System: Windows7 64bit

grepotool.jpg
 
Zuletzt bearbeitet von einem Moderator:
Um welche Welt geht es denn? Irgendeine Welt?

Hast du wirklich Version 2.0.15?


Das unter Application nichts steht hängt damit zusammen dass dir die Sprachdateien fehlen ;)
 

toleranzgrenze

Gast
Um welche Welt geht es denn? Irgendeine Welt?

Hast du wirklich Version 2.0.15?


Das unter Application nichts steht hängt damit zusammen dass dir die Sprachdateien fehlen ;)

Welt ist egal...hätte schon mehrere ausprobiert...immer dasselbe

Version 2.0.15 hätte ich

grepotool version.jpg

so schaut der ordner aus:

grepotool ordner.jpg
 
Zuletzt bearbeitet von einem Moderator:
Nein hast du nicht. Du hast die falschen .dll Dateien...ich kann mir aber denken wo das Problem liegt. Vermutlich hattest du schon mal irgendwann die aktuellste Version oder der Update-Vorgang ist fehlgeschlagen (das hätte er eigentlich aber melden müssen) aufgrund von zB ner Firewall oder nem Antivirenprogramm :(

Wenn du dich mit dem regedit auskennst dann könntest du dort nach Grepo suchen und die entsprechenden Einträge löschen und dann das Tool noch mal neu starten. (Bitte wirklich nur wenn du dich auskennst mit sowas!!)

Wenn nicht dann bitte folgendes mal probieren:
1. Grepo-Tool beenden
2. Zip laden: 2.0.15 Bibliotheken (enthält die 2.0.15er dlls + Sprachdateien)
3. Zip in den Ordner entpacken (der Ordner aus deinem Screenshot)
4. Wenn gefragt wird ob etwas überschrieben werden soll: bestätigen
5. Grepo-Tool neu starten.

Falls das nicht klappt oder du irgendeinen Schritt nicht verstanden hast melde dich bitte mal per PN bei mir oder adde mich im Skype ;)
 

toleranzgrenze

Gast
Danke diabhoil!

Hab die Bibliotheken geladen und jetzt funkt wieder alles. Mit regedit hatte ich es zuvor schonmal versucht, hat aber auch nicht gefruchtet. Dank Deiner Hilfe erfreue ich mich jetzt wieder an dem Tool
 
So, auf de67 läuft es, täglich, aber bei neuen Welten scheint es ein Problem zu geben, de68 Billys hängt schpn am zweiten Tag

Jetzt ist mir der Fehler auch aufgefallen :D
Tritt wirklich nur bei neuen Welten am Anfang aus..liegt einfach daran, dass es noch keine Eroberungen gibt und er trotzdem versucht die runter zu laden und dann das ganze Update der Towns usw. abbricht :(
 

Snoop007

Gast
Hallo, hab vorgestern den Tip für dieses Tool bekommen. Hab es erst nicht hinbekommen, dann nachdem ich diese 23 Seiten hier gelesen habe, funktioniert es einigermaßen.
Habe die Serverdaten (de68) manuell reinkopiert. Tolle Karte. Die anderen funktionen (angriffsplaner etc.) laufen leider nicht.
Damit kann ich leben, aber ich kriege es nicht hin das sich die Weltdaten aktualisieren.
Bin ein Linux-user, könnte sein das es daran liegt.
Ist zwar schon länger ruhig hier in dem Thread , aber evtl. kann mir jemand helfen. Leider bin ich nicht so fit in Computerdingen,
die Sache mit Mysql war schon zuviel. Falls es noch eine einfache Möglichkeit gibt die Serverdaten Aktuell zu halten wäre ich dankbar.
Ansonsten muß ich eben alle paar Tage mal die alten Daten löschen und neue reinkopieren.

Danke schonmal für's lesen.
 
Ehrlich gesagt weiß ich nicht was ich dazu schreiben soll :D

Das hier ist erst mal ein Windows Programm was normalerweise nicht für Linux gemacht ist..es läuft dort zwar auch, muss von jedem Nutzer aber selber kompiliert werden unter Linux und wenn ich mich nicht irre müssten zB auch die Color-Dialoge und einige andere Sachen im Code neu geschrieben werden damit es problemlos unter Linux läuft.
Dann schreibst du was mit mysql...Grepotool verwendet keine mysql Datenbank. Das Tool speichert die Programmdaten binär ab...:eek:

LG
 

Snoop007

Gast
Danke das du antwortest .Das mit Mysql stammt von der ersten Seite , hab ich dann aber wohl falsch verstanden.
Hätte ich eh nicht hinbekommen. Hatte gehofft das evtl. ein Linux-experte da ne relativ einfache Lösung zum aktualisieren der Welten
hat. Bei mir läuft es mit hilfe von Wine+playonlinux relativ gut. Die Karte funktioniert, und die ist echt erste Sahne.
Ich aktualisiere dann weiter manuell. Serverdaten gibs ja. Und sind ja "nur" 11 Ordner betroffen. Lohnt sich der Aufwand.
 
Ja kann es vielleicht sein dass er einfach die Dateien nicht runterlädt weil er ggf. kein Internet hat aus Wine heraus? Oder vielleicht ist es nen Rechteproblem? Kenne mich da jetzt mit wine leider nicht so gut aus. Ich hatte es damals halt für linux kompiliert. Unter Wine wollte es auch nicht starten :D
 

Snoop007

Gast
unter wine alleine läuft auch nichts. Erst zusammen mit Playonlinux gehts einigermaßen. Es tut so als hätte es eine Verbindung, lädt und gibt dann die Fehlermeldung raus das wichtige Daten nicht runtergeladen werden konnten Sowohl beim update als auch bei den Serverdaten. Es installiert sich auch nicht komplett, also wird es ein größeres Problem sein. Es ging mir nur um die aktualisierung der Serverdaten. Aber das wird nicht gehen. Evtl. werde ich doch ein Dual-boot system installieren.
Kannst du mir evtl. sagen ob es unter allen Windows läuft oder ob ich ein bestimmtes nehmen sollte ( Windows 8 stinkt, deswegen bin ich zu Linux gewechselt.)
 
Also ich nutze derzeit nen Windows 7. Da läuft es auf jeden Fall. Vom Prinzip her sollte es aber auf allen möglichen Windows Versionen laufen für die QT lauffähig ist :D

Ach ja Windows 8.1 ist im Gegensatz zu Windows 8 viel besser nutzbar. Lässt sich praktisch wie ein Windows 7 nutzen mit kleinen Unterschieden...je nachdem wie du dich mit Linux und kompilieren auskennst können wir aber auch darüber mal reden (dann könntest du mich mal per PN anschreiben ;) )

LG
 

Snoop007

Gast
Kenne ich mich leider nicht wirklich mit aus. Würde wahrscheinlich sehr lange dauern mir das zu erklären. Das möchte ich dir nicht zumuten.
Ich werde versuchen ein Dual-Boot System zu installieren . Wenn ich dann noch fragen habe zu Grepo-tool ,kann ich sie für das Betriebssystem stellen für daß das Programm geschrieben wurde.

Vielen Dank trotzdem für das Angebot.
 

Supermeier

Gast
Ich werde versuchen ein Dual-Boot System zu installieren . Wenn ich dann noch fragen habe zu Grepo-tool ,kann ich sie für das Betriebssystem stellen für daß das Programm geschrieben wurde.

Vielen Dank trotzdem für das Angebot.
Wie sieht es denn aus mit ner virtuellen Umgebung? Dann kannst Du das Windows parallel laufen lassen und musst nicht extra dafür neu starten.
 

Snoop007

Gast
Oha, muß ich mich noch deutlicher als Computer-Deppen outen ;)
Ich sag nur Schuster bleib bei deinen Leisten. Ich denke das Dual-Boot-System krieg ich noch hin, aber da hört es dann aber auch
bei mir auf.

Aber auch dir danke für den Tip.
 
Virtuelles System ist noch einfacher und sicherer. Dual Boot ist immer so eine Sache..aber naja für ein virtuelles System braucht man leider auch entsprechende Leistungsreserven sonst läuft weder der Host noch die virtuelle Maschine optimal. Und GrepoTool braucht schon ein wenig Leistung :(
 
Hey,

habe nen neuen Lappi mit Win 8 + Patches...meine es wäre Win 8.1...ich öffne die Datei per WinZip und starte die exe, allerdings wird mir dann angezeigt, dass die Datei GTcore.dll fehlt, obwohl ich sie im Verzeichnis sehe.

Habe auch schon häufiger versucht die Datei herunterzuladen und zu installieren.

Wäre dankbar für Hilfe.

LG
Max
 

Supermeier

Gast
Hey,
ich öffne die Datei per WinZip und starte die exe, allerdings wird mir dann angezeigt, dass die Datei GTcore.dll fehlt, obwohl ich sie im Verzeichnis sehe.
Öffnest Du die Datei mit WinZip oder entpackst Du sie?
Die ZIP-Datei muss in ein Verzeichniss entpackt werden, dann die darin enthaltene Exe starten.