Neues Projekt: Grepostats + Grepomaps + vieles mehr als eigenständiges Programm

Hallöchen,

gäbe es die Möglichkeit, dass man mehrere Allianzen auswählen kann (Klick-Scroll-ShiftKlick) und dann mit Rechtsklick eine gemeinsame Farbe zuweisen kann? Dann könnte man neuen Miniallies eine Farbe zuweisen und muss nicht alle einzeln anwählen.
Ab einer gewissen Anzahl an Berichten, wird kein neuer Bericht rein geladen - lässt sich die Begrenzung rausnehmen?

LG, CK
 
Laufzeitenunterschiede auf MOCHLOS
Tool: 02:08:28 (Differenz= -00:06:15)
Spiel: 02:14:43

Tool: 01:30:08 (Differenz= -00:06:15)
Spiel: 01:36:23
 
Danke für die Info. Ja da muss ich anscheinend die Möglichkeit einbauen, die Weltgeschwindigkeit von Hand einzustellen. Es sei denn, jemand hat eine andere zündende Idee. Seit heute startet das Tool aber sowieso garnicht mehr. Ich vermute, dass Inno etwas am Download der Weltdaten verstellt hat. Muss da erstmal genauer nachschauen, woran das nun liegt. Sobald ich etwas weiß, poste ich das hier.

Ich hatte eigentlich gehofft, hierfür kein Update mehr zwischenschieben zu müssen. Lieber ein neues Kartentool bauen und nicht immer mehr Features in diese eh schon völlig überfrachtete Wollmilchsau reinfummeln...
 
Danke für jede Minute, die du investierst


Bei mir motzt es nur, dass es keine Antwort von den "Servern" bekommt... "Inno hat was zerschossen - Inno hat was zerschossen"
 
Inno bietet im Moment anscheinend nicht mehr alle Daten an..zB die zu Städten, Allianzen...bzw. zumindest nicht unter der url zu der man umgeleitet wird..
 
Zuletzt bearbeitet:
Grepotool startet nicht mehr...kommt immer der Fehler, das es nicht auf die Server und auf de1.grepolis.de zugreifen kann...

Kam vor 3 Tagen ganz plötzlich...hatte es noch offen und immer aktualisiert...da merkte ich, das die zahlen sich nicht ändern, sprich Punkte...

Als dann alle anderen von uns das auch so hatten, habe ich es geschlossen....nun kackt es immer beim Startbildschirm ab...beendet sich selbst...auch nach neuem Download...

Kann uns jemand helfen??
 
Bei mir sieht es so aus:


wähle ich da nun eine Welt aus, ist der Weiter-Button nicht mehr ausgegraut. Klicke ich den aber an, stürzt das Tool ab und lässt sich auch nicht mehr öffnen. Erst nach Neustart des PCs kann man das Tool wieder anklicken, aber dann passiert wieder das gleiche.
 
Das kann ich leider nicht sagen


Am besten mal versuchen, dem eine Mail zu schreiben oder einfach warten. Kann auch ein Serverfehler sein
 
Angeboten werden die Daten wohl, aber auch Quack hatte Probleme mit der Umleitung, siehe hier:

https://forum.de.grepolis.com/showthread.php?20742-Quack-Toolsammlung&p=515429&viewfull=1#post515429

Er scheint das gelöst zu haben für seine grepoworld.com, vielleicht schließt Ihr Euch mal kurz zu dem Thema.
Ja - es liegt ganz offenbar an dieser neuen Umleitung der Downloads von Http:// zu einer https:// -Addresse. Leider scheint HTTPS von der Laufzeitbibliothek, die ich für das Grepotool benutze nicht by default unterstützt zu werden. Ich bin noch auf der Suche nach einer einfachen Lösung, fürchte aber, dass es dafür nötig sein wird, OpenSsl zu nutzen.

OpenSsl wiederum unterliegt gewissen regionalen Auflagen, da es Crypto-Software ist und nicht einfach so überall benutzt werden darf. BigBrother hat da also wieder seine Finger im Spiel. Ich darf die entsprechenden nötigen dateien evtl. garnicht zusammen mit dem Tool zum Download anbieten. Das aber nur am Rande. Sobald ich eine Lösung habe, poste ich sie hier.
 
Habe den Code eben selber mal überflogen. Wird nicht so einfach werden.

Was hältst du von einer SQL Datenbank, die die angebotenen Daten automatisch abspeichert und die dann im Tool aufgerufen werden können?

Muss man halt nur darauf schauen, dass diese Datenbanken vom Speicherplatz her nicht zu riesig wird. Heißt also regelmäßiges Löschen


Ist keine Dauerlösung aber für´s Erste sollte das reichen
 
Zuletzt bearbeitet: